aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-18 17:04:57 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-18 18:58:20 -0700
commitb62ed68007eb9429a3f5e40ce56b0094c57d6414 (patch)
tree61c48c09315cac082908fa46853c80a92aabb4c8
parent030cc5570ca9caa0f2b7392c6df6667582dee72d (diff)
glib2: fix host build
Seems to need -liconv. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/glib2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index 5f102d235..a56d83de1 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glib2
PKG_VERSION:=2.64.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/glib/2.64
@@ -42,6 +42,7 @@ define Package/glib2/description
The GLib library of C routines
endef
+HOST_LDFLAGS += -liconv
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections