aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-20 19:56:24 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-22 19:27:21 -0800
commitb599c11aa8cf7cf799f89bfe080ad8141a8a0727 (patch)
treebaff1bdf3c18758c7282fdfddc265a08b375c120
parent55593507ab2552acd03e1e8fcdd01471bc7f509f (diff)
zstd: update to 1.4.8
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/zstd/Makefile6
-rw-r--r--utils/zstd/patches/010-python.patch21
2 files changed, 3 insertions, 24 deletions
diff --git a/utils/zstd/Makefile b/utils/zstd/Makefile
index 06030ec75..c25a2f231 100644
--- a/utils/zstd/Makefile
+++ b/utils/zstd/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zstd
-PKG_VERSION:=1.4.5
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.8
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
-PKG_HASH:=2c2366874bc449ff539614266d8c0d6ecdb4baf30bb65609c239ab4ed23c03c7
+PKG_HASH:=c7ea10e20dd61b457220455e3cf553069987b968b7c63d1b9d46acbdb45623eb
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/utils/zstd/patches/010-python.patch b/utils/zstd/patches/010-python.patch
deleted file mode 100644
index c35c515c3..000000000
--- a/utils/zstd/patches/010-python.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/build/meson/meson.build
-+++ b/build/meson/meson.build
-@@ -22,7 +22,6 @@ project('zstd',
- cc = meson.get_compiler('c')
- cxx = meson.get_compiler('cpp')
- pkgconfig = import('pkgconfig')
--python3 = import('python').find_installation()
- windows_mod = import('windows')
-
- host_machine_os = host_machine.system()
-@@ -40,8 +39,8 @@ compiler_msvc = 'msvc'
- zstd_version = meson.project_version()
-
- zstd_h_file = join_paths(meson.current_source_dir(), '../../lib/zstd.h')
--GetZstdLibraryVersion_py = files('GetZstdLibraryVersion.py')
--r = run_command(python3, GetZstdLibraryVersion_py, zstd_h_file)
-+GetZstdLibraryVersion_py = find_program('GetZstdLibraryVersion.py', native : true)
-+r = run_command(GetZstdLibraryVersion_py, zstd_h_file)
- if r.returncode() == 0
- zstd_version = r.stdout().strip()
- message('Project version is now: @0@'.format(zstd_version))