aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2015-12-20 21:20:23 +0100
committerJohn Crispin <john@phrozen.org>2015-12-20 21:20:23 +0100
commitb44c01a072adf335cd4280ebcb10e0a9cdfbd51f (patch)
tree898ddd9a1cb31676796074f0199d345ae479aded
parenta0391c4f758b6f3743993a3039041cd12fb862be (diff)
parente5ca27a97ced84c6bce0799de81cceb9c32e9cc7 (diff)
Merge pull request #2147 from commodo/node-x86-build-fix
node: fix build on x86 & x86.64 targets
-rw-r--r--lang/node/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/node/Makefile b/lang/node/Makefile
index 243c8a5b6..147410499 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=node
PKG_VERSION:=v0.12.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=node-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nodejs.org/dist/${PKG_VERSION}
@@ -40,8 +40,13 @@ define Package/node/description
package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
endef
+CPU:=$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))
+
+MAKE_VARS += \
+ DESTCPU=$(CPU)
+
CONFIGURE_ARGS= \
- --dest-cpu=$(CONFIG_ARCH) \
+ --dest-cpu=$(CPU) \
--dest-os=linux \
--without-snapshot \
--shared-zlib \