aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2017-02-28 20:35:12 +0100
committerDirk Brenken <dev@brenken.org>2017-02-28 20:35:12 +0100
commitb3b9972eacdf4acc5ff231f7aa5c32d14fbc4841 (patch)
tree4c5c7a5a6f4cf12785ba84a16b83447fe163d7e3
parented470f0dcc66f42bc57e3795e3c9f37629e2cbcd (diff)
adblock: release 2.4.0 (release 2)
* add missing sort step if tld compression was disabled Signed-off-by: Dirk Brenken <dev@brenken.org>
-rw-r--r--net/adblock/Makefile2
-rwxr-xr-xnet/adblock/files/adblock.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 917c51425..9c7f746b8 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
PKG_VERSION:=2.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 62d1a1c54..a470d0bf7 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -10,7 +10,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.4.0"
+adb_ver="2.4.0-2"
adb_enabled=1
adb_debug=0
adb_backup=0
@@ -406,8 +406,10 @@ f_main()
awk -F "." '{for(f=NF;f > 1;f--) printf "%s.", $f;print $1}' "${adb_tmpfile}" | sort -u > "${adb_tmpload}"
awk '{if(NR==1){tld=$NF};while(getline){if($NF !~ tld"\\."){print tld;tld=$NF}}print tld}' "${adb_tmpload}" > "${adb_tmpfile}"
awk -F "." '{for(f=NF;f > 1;f--) printf "%s.", $f;print $1}' "${adb_tmpfile}" > "${adb_tmpload}"
- mv -f "${adb_tmpload}" "${adb_tmpfile}"
+ else
+ sort -u "${adb_tmpfile}" > "${adb_tmpload}"
fi
+ mv -f "${adb_tmpload}" "${adb_tmpfile}"
f_list backup
else
f_list restore