aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-03-21 22:45:43 +0100
committerDaniel Golle <daniel@makrotopia.org>2016-03-21 23:04:28 +0100
commitb0f8e994f3827e52b6d7cf7232628567575c71b5 (patch)
tree32873b98e296d0f6c12fb2876ef935d5e870d23a
parent5e28a2e0d7b7413011159fb744014e6ac34f6f28 (diff)
postgresql: update source to 9.5.1 and refresh patches
Setting the additional include path for host-build of ecpg is no longer required and started breaking the build (PostgeSQL BUG-14033), remove it. Also, pgsql-server no longer requires shadow-su since procd can take care of starting it running under the appropriate user. Moving the dependency to pgsql-cli makes sense as the 'su' command is still needed to boot-strap a new data directory and also commonly used for other administration tasks. However, in that way the CLI and shadow-su can be removed during production once pgsql-server has been setup. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--libs/postgresql/Makefile10
-rw-r--r--libs/postgresql/patches/001-configure_fixes.patch2
-rw-r--r--libs/postgresql/patches/200-ranlib.patch4
-rw-r--r--libs/postgresql/patches/800-busybox-default-pager.patch4
4 files changed, 10 insertions, 10 deletions
diff --git a/libs/postgresql/Makefile b/libs/postgresql/Makefile
index 72b99b627..2ad5b54e0 100644
--- a/libs/postgresql/Makefile
+++ b/libs/postgresql/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=postgresql
-PKG_VERSION:=9.4.4
+PKG_VERSION:=9.5.1
PKG_RELEASE:=1
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=PostgreSQL
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=\
http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=1fe952c44ed26d7e6a335cf991a9c1c6
+PKG_MD5SUM:=11e037afaa4bd0c90bb3c3d955e2b401
PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
PKG_FIXUP:=autoreconf
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/libpq
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+zlib +libreadline +libpthread +libncurses +shadow-utils +shadow-su
+ DEPENDS:=+zlib +libreadline +libpthread +libncurses
TITLE:=PostgreSQL client library
URL:=http://www.postgresql.org/
SUBMENU:=database
@@ -42,7 +42,7 @@ endef
define Package/pgsql-cli
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libpq +USE_UCLIBC:librt
+ DEPENDS:=+libpq +USE_UCLIBC:librt +shadow-utils +shadow-su
TITLE:=Command Line Interface (CLI) to PostgreSQL databases
URL:=http://www.postgresql.org/
SUBMENU:=database
@@ -116,7 +116,7 @@ define Build/Configure
--enable-depend \
--with-system-timezone=/tmp \
);
- $(MAKE) -C $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc CC="$(HOSTCC)" CFLAGS+="-I../../libpq"
+ $(MAKE) -C $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc CC="$(HOSTCC)"
mv $(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg \
$(PKG_BUILD_DIR)/src/interfaces/ecpg/preproc/ecpg.host
$(MAKE) -C $(PKG_BUILD_DIR)/src/timezone CC="$(HOSTCC)"
diff --git a/libs/postgresql/patches/001-configure_fixes.patch b/libs/postgresql/patches/001-configure_fixes.patch
index 2edaba6a0..bc0d2e15e 100644
--- a/libs/postgresql/patches/001-configure_fixes.patch
+++ b/libs/postgresql/patches/001-configure_fixes.patch
@@ -2,7 +2,7 @@
+++ b/configure.in
@@ -25,7 +25,7 @@ recommended. You can remove the check f
your responsibility whether the result works or not.])])
- AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
+ AC_COPYRIGHT([Copyright (c) 1996-2015, PostgreSQL Global Development Group])
AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
-AC_CONFIG_AUX_DIR(config)
+AC_CONFIG_AUX_DIR([config])
diff --git a/libs/postgresql/patches/200-ranlib.patch b/libs/postgresql/patches/200-ranlib.patch
index 5fc6d3db9..5232c74a2 100644
--- a/libs/postgresql/patches/200-ranlib.patch
+++ b/libs/postgresql/patches/200-ranlib.patch
@@ -1,8 +1,8 @@
--- a/src/port/Makefile
+++ b/src/port/Makefile
-@@ -52,6 +52,7 @@ uninstall:
-
+@@ -53,6 +53,7 @@ uninstall:
libpgport.a: $(OBJS)
+ rm -f $@
$(AR) $(AROPT) $@ $^
+ $(RANLIB) libpgport.a
diff --git a/libs/postgresql/patches/800-busybox-default-pager.patch b/libs/postgresql/patches/800-busybox-default-pager.patch
index 1be196991..0c6086783 100644
--- a/libs/postgresql/patches/800-busybox-default-pager.patch
+++ b/libs/postgresql/patches/800-busybox-default-pager.patch
@@ -1,8 +1,8 @@
--- a/src/bin/psql/print.h
+++ b/src/bin/psql/print.h
-@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
- extern void setDecimalLocale(void);
+@@ -197,10 +197,6 @@ extern void setDecimalLocale(void);
extern const printTextFormat *get_line_style(const printTableOpt *opt);
+ extern void refresh_utf8format(const printTableOpt *opt);
-#ifndef __CYGWIN__
-#define DEFAULT_PAGER "more"