aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-11-13 09:26:19 +0100
committersbyx <steven@midlink.org>2014-11-13 09:26:19 +0100
commitb0dd84dcb952b96e41d6ebc503b14bdc90c862b1 (patch)
tree1438eb246b4bf6c78519a8d0522f3d26cc7a2a3d
parent3805f5183cb144a372f5e35fba13a875b45e690a (diff)
parent286e50a0bd7631162002dc613979cb09b23d81d0 (diff)
Merge pull request #540 from commodo/python-pip
python-pip: first revision
-rw-r--r--lang/python-pip/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/lang/python-pip/Makefile b/lang/python-pip/Makefile
new file mode 100644
index 000000000..c0de9faa3
--- /dev/null
+++ b/lang/python-pip/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pip
+PKG_VERSION:=1.5.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=pip-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pip/
+PKG_MD5SUM:=01026f87978932060cc86c1dc527903e
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/pip-$(PKG_VERSION)
+PKG_USE_MIPS16:=0
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-pip
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Tool for installing Python packages.
+ URL:=https://pip.pypa.io
+ DEPENDS:=+python +python-setuptools
+endef
+
+define Package/python-pip/description
+ A tool for installing and managing Python packages.
+endef
+
+PYTHONPATH:=$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
+define Build/Compile
+ $(INSTALL_DIR) $(PYTHONPATH)
+ $(call Build/Compile/PyMod,,\
+ install --prefix="$(PKG_INSTALL_DIR)/usr" \
+ )
+endef
+
+define PyPackage/python-pip/filespec
++|/usr/lib/python$(PYTHON_VERSION)
+endef
+
+define PyPackage/python-pip/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+endef
+
+$(eval $(call PyPackage,python-pip))
+$(eval $(call BuildPackage,python-pip))
+