aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-08-19 10:33:07 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-08-20 10:05:51 +0000
commitaf41e07e10ddd1ee55514298aa216fc4fec6882c (patch)
tree98d442dc8ca6252e5d5e12143cc0b74a8a97c604
parentf4c2d9fb5902d2f22383f75c487c6b2d07a64ef3 (diff)
dtc: backport patch to export fdt_check_full()
This is required for configure script of QEMU to detect presence of system libfdt library Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--libs/dtc/Makefile2
-rw-r--r--libs/dtc/patches/0002-export-fdt_check_full-and-others.patch29
2 files changed, 30 insertions, 1 deletions
diff --git a/libs/dtc/Makefile b/libs/dtc/Makefile
index a4093e1e5..a806dac19 100644
--- a/libs/dtc/Makefile
+++ b/libs/dtc/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dtc
PKG_VERSION:=1.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=c672e443c9f7e39f5a7c8e602da6777f9ad55ad70de87de300a43828c8050172
PKG_SOURCE_URL:=@KERNEL/software/utils/dtc
diff --git a/libs/dtc/patches/0002-export-fdt_check_full-and-others.patch b/libs/dtc/patches/0002-export-fdt_check_full-and-others.patch
new file mode 100644
index 000000000..bef8c1024
--- /dev/null
+++ b/libs/dtc/patches/0002-export-fdt_check_full-and-others.patch
@@ -0,0 +1,29 @@
+From eac2ad495b29f15d78daa2a7226653f36515cd7a Mon Sep 17 00:00:00 2001
+From: David Gibson <david@gibson.dropbear.id.au>
+Date: Mon, 25 Mar 2019 14:52:47 +1100
+Subject: [PATCH] Update version.lds again
+
+Yet again, we've added several functions to libfdt that were supposed
+to be exported, but forgotten to add them to the versio.lds script.
+This adds them.
+
+Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
+---
+ libfdt/version.lds | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libfdt/version.lds b/libfdt/version.lds
+index 9f5d708..a5fe62d 100644
+--- a/libfdt/version.lds
++++ b/libfdt/version.lds
+@@ -66,6 +66,10 @@ LIBFDT_1.2 {
+ fdt_resize;
+ fdt_overlay_apply;
+ fdt_get_string;
++ fdt_get_max_phandle;
++ fdt_check_full;
++ fdt_setprop_placeholder;
++ fdt_property_placeholder;
+ local:
+ *;
+ };