aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-08-17 18:38:37 +0300
committerGitHub <noreply@github.com>2016-08-17 18:38:37 +0300
commitae8304f57f9c5b8088aea0a0febbade99c7fd70b (patch)
treeee63b80b95a4277383135d76425a93b9923652a5
parent13014e3633c614a660bdc516d896c0a89be1f4e0 (diff)
parentc57f915028caf37f7e3f0e00b7b928835ba196b4 (diff)
Merge pull request #3075 from jp-bennett/master
Updates to nano and fwknop
-rw-r--r--net/fwknop/files/fwknopd.init2
-rw-r--r--utils/nano/Makefile4
-rw-r--r--utils/nano/patches/010-fix-enable-tiny18
3 files changed, 22 insertions, 2 deletions
diff --git a/net/fwknop/files/fwknopd.init b/net/fwknop/files/fwknopd.init
index 94c426c47..c342c20b2 100644
--- a/net/fwknop/files/fwknopd.init
+++ b/net/fwknop/files/fwknopd.init
@@ -53,6 +53,8 @@ gen_confs()
if [ "$option" = "uci_enabled" ] && [ "$value" -eq 1 ] ; then
> /etc/fwknop/fwknopd.conf
> /etc/fwknop/access.conf
+ chmod 600 /etc/fwknop/fwknopd.conf
+ chmod 600 /etc/fwknop/access.conf
UCI_ENABLED=1
fi
}
diff --git a/utils/nano/Makefile b/utils/nano/Makefile
index 0c4cfacdf..d3492a931 100644
--- a/utils/nano/Makefile
+++ b/utils/nano/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nano
-PKG_VERSION:=2.6.0
+PKG_VERSION:=2.6.3
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.nano-editor.org/dist/v2.6/
-PKG_MD5SUM:=89051965a1de963190696348bc291b86
+PKG_MD5SUM:=1213c7f17916e65afefc95054c1f90f9
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
diff --git a/utils/nano/patches/010-fix-enable-tiny b/utils/nano/patches/010-fix-enable-tiny
new file mode 100644
index 000000000..ec3211d5e
--- /dev/null
+++ b/utils/nano/patches/010-fix-enable-tiny
@@ -0,0 +1,18 @@
+--- nano-2.6.3/src/winio.c 2016-08-10 04:22:23.000000000 -0500
++++ nano-2.6.3.new/src/winio.c 2016-08-17 00:58:35.663135848 -0500
+@@ -502,7 +502,6 @@
+ return sc_seq_or(do_prev_block, 0);
+ else if (retval == controldown)
+ return sc_seq_or(do_next_block, 0);
+-#endif
+
+ /* When not running under X, check for the bare arrow keys whether
+ * the Ctrl key is being held together with them. */
+@@ -521,6 +520,7 @@
+ return sc_seq_or(do_next_word_void, 0);
+ }
+ }
++#endif
+
+ switch (retval) {
+ #ifdef KEY_SLEFT