aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2019-11-11 08:40:03 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2019-11-11 08:42:23 -0300
commitae057405f829cd3df95a7d6fcf9f0650fe298fd2 (patch)
tree3fcb2b824fa786b2dab5b2492e582e4ab03dcdbc
parente38810f38e8772c1f76397b64f71ac6f285fa90e (diff)
seafile-server: depend on libevent2-threads
seafile-server uses libevhtp pthreads support. libevhtp needs libevent2-pthreads for that. However, since there is no installable package for libevhtp--the library is build static-only--then seafile-server, its consumer, needs to add the dependecy. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
-rw-r--r--net/seafile-server/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/seafile-server/Makefile b/net/seafile-server/Makefile
index aabb4eb07..627682161 100644
--- a/net/seafile-server/Makefile
+++ b/net/seafile-server/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=seafile-server
PKG_VERSION:=6.3.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_LICENSE:=GPL-3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -40,8 +40,8 @@ define Package/seafile-server
TITLE:=Seafile server
URL:=https://seafile.com/
DEPENDS:=+libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub +sqlite3-cli \
- +python-mysqlclient +python-urllib3 \
- +jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient +oniguruma \
+ +python-mysqlclient +python-urllib3 +jansson +libevent2 +libevent2-openssl \
+ +libevent2-pthreads +zlib +libzdb +libsqlite3 +libmysqlclient +oniguruma \
+libpthread +libuuid +bash +procps-ng +procps-ng-pkill +SEAFILE_FUSE_SUPPORT:libfuse $(ICONV_DEPENDS)
MENU:=1
endef