aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2019-05-21 13:58:25 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2019-05-21 13:58:25 +0900
commitad991b43747f7e9073beaaef66d4a83b34662fd7 (patch)
tree648e7b599e8755069cc94414e5897191ce959def
parent727d2b5a61d4aed76c9b851afb1828bcd548549f (diff)
node-serialport: fix powerpc build fail
fix powerpc 'node-serialport' package build fail divide node-serialport' into node-serialport' and node-serialport-bindings node-serialport-bindings PR : https://github.com/openwrt/packages/pull/9045 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
-rw-r--r--lang/node-serialport/Makefile4
-rw-r--r--lang/node-serialport/patches/001-turn_off_depends.patch10
2 files changed, 12 insertions, 2 deletions
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index 38e8fbef0..8f1eadf1b 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=7.1.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
@@ -31,7 +31,7 @@ define Package/node-serialport
CATEGORY:=Languages
TITLE:=Node.js package to access serial ports
URL:=https://serialport.io/
- DEPENDS:=+node +node-npm
+ DEPENDS:=+node +node-npm +node-serialport-bindings
endef
define Package/node-serialport/description
diff --git a/lang/node-serialport/patches/001-turn_off_depends.patch b/lang/node-serialport/patches/001-turn_off_depends.patch
new file mode 100644
index 000000000..8e36ac7c6
--- /dev/null
+++ b/lang/node-serialport/patches/001-turn_off_depends.patch
@@ -0,0 +1,10 @@
+--- a/package.json
++++ b/package.json
+@@ -41,7 +41,6 @@
+ ],
+ "dependencies": {
+ "@serialport/binding-mock": "^2.0.5",
+- "@serialport/bindings": "^2.0.8",
+ "@serialport/parser-byte-length": "^2.0.2",
+ "@serialport/parser-cctalk": "^2.0.2",
+ "@serialport/parser-delimiter": "^2.0.2",