aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-07-22 22:57:30 +0200
committerGitHub <noreply@github.com>2019-07-22 22:57:30 +0200
commitad6ed836a59d986b2a449ec958d0581b1959a338 (patch)
tree18ee57f0ac30b04e656579c06558905c17f8f289
parent626949defca45b249659136761b354b257f7de76 (diff)
parentebdeca0108df1d77874be91c706e9697d0ace8a4 (diff)
Merge pull request #9521 from shenek/feature_python-cachelib
python: cachelib package added
-rw-r--r--lang/python/python-cachelib/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-cachelib/Makefile b/lang/python/python-cachelib/Makefile
new file mode 100644
index 000000000..3f59aca1b
--- /dev/null
+++ b/lang/python/python-cachelib/Makefile
@@ -0,0 +1,40 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-cachelib
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=cachelib-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/c/cachelib
+PKG_HASH:=8b889b509d372095357b8705966e1282d40835c4126d7c2b07fd414514d8ae8d
+PKG_BUILD_DIR:=$(BUILD_DIR)/cachelib-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Stepan Henek <stepan.henek@nic.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-cachelib
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=cachelib
+ URL:=https://github.com/pallets/cachelib
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-cachelib/description
+ A collection of cache libraries in the same API interface.
+ Extracted from werkzeug.
+endef
+
+$(eval $(call Py3Package,python3-cachelib))
+$(eval $(call BuildPackage,python3-cachelib))
+$(eval $(call BuildPackage,python3-cachelib-src))