aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-30 12:18:09 -0700
committerGitHub <noreply@github.com>2019-04-30 12:18:09 -0700
commitaa920879d1a363306a27f6741e1bb6d71c661fcc (patch)
treee59d1f8185ec3b93727d00c144aff42914c01b71
parent3d3cd5d394814d3046f3187c6734030ef8732f5e (diff)
parent44c24203a57d110f9b8c8cebfcbf24f2503d430b (diff)
Merge pull request #7877 from ammubhave/add_gflags_to_glog_stacked
libglog: Add gflags as a dependency for glog
1 files changed, 4 insertions, 2 deletions
diff --git a/libs/libglog/Makefile b/libs/libglog/Makefile
index dcaab6afb..928f48297 100644
--- a/libs/libglog/Makefile
+++ b/libs/libglog/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glog
PKG_VERSION:=0.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/google/glog/tar.gz/v$(PKG_VERSION)?
@@ -16,13 +16,15 @@ PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=libgflags
+
include $(INCLUDE_DIR)/package.mk
define Package/glog
SECTION:=libs
CATEGORY:=Libraries
TITLE:=C++ implementation of the Google logging module
- DEPENDS:= +libstdcpp +libpthread
+ DEPENDS:= +libstdcpp +libpthread +gflags
URL:=https://github.com/google/glog
MAINTAINER:=Amir Sabbaghi <amir@pichak.co>
endef