aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-11-16 16:22:47 +0800
committerGitHub <noreply@github.com>2023-11-16 16:22:47 +0800
commita7b38889b1ebdbf29c97c9bb5fe399974cace94b (patch)
tree3afad3a8a7525ee2dfb47c14da629d363132609f
parentcee97bce366c2b4b4902d06617afcb9436339ed8 (diff)
parentc4c1b93f64969b5a92e59d0cf51c6358a6ed4a60 (diff)
Merge pull request #22646 from dynasticorpheus/fx
fx: add new package
-rw-r--r--utils/fx/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/utils/fx/Makefile b/utils/fx/Makefile
new file mode 100644
index 000000000..9642d6070
--- /dev/null
+++ b/utils/fx/Makefile
@@ -0,0 +1,38 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fx
+PKG_VERSION:=31.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/antonmedv/fx/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=8408047ef42506aac44aa805de209dd64ae4fc084e76bee8e24112ffbdc2d5dc
+
+PKG_MAINTAINER:=Fabian Lipken <dynasticorpheus@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=no-mips16
+
+GO_PKG:=github.com/antonmedv/fx
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/fx
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Terminal JSON viewer & processor
+ URL:=https://github.com/antonmedv/fx/
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+endef
+
+define Package/fx/description
+ Fx is a dual-purpose command-line tool tailored for JSON, providing
+ both a terminal-based JSON viewer and a JSON processing utility.
+endef
+
+$(eval $(call GoBinPackage,fx))
+$(eval $(call BuildPackage,fx))