aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSibren Vasse <github@sibrenvasse.nl>2023-12-20 17:01:50 +0100
committerRosen Penev <rosenp@gmail.com>2024-01-06 13:48:02 -0800
commita79c49578ca136556bd10d8990aa52ef4eb0664b (patch)
tree12e261afa89aca9d8e0817c3e1abc83d304381d8
parente8dfc6abbee88f35887c66ec785b081252d6d07d (diff)
openssh: fix build failure on powerpc_8548
https://github.com/openssh/openssh-portable/commit/1036d77b34a5fa15e56f516b81b9928006848cbd Signed-off-by: Sibren Vasse <github@sibrenvasse.nl>
-rw-r--r--net/openssh/Makefile2
-rw-r--r--net/openssh/patches/010-better_fzero-call-detection.patch52
2 files changed, 54 insertions, 0 deletions
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index 2997ee56f..4a6326fc9 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -20,6 +20,8 @@ PKG_LICENSE:=BSD ISC
PKG_LICENSE_FILES:=LICENCE
PKG_CPE_ID:=cpe:/a:openssh:openssh
+#While bumping new version, make sure that it works without it, so it can be removed.
+PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=
PKG_CONFIG_DEPENDS := \
CONFIG_OPENSSH_LIBFIDO2
diff --git a/net/openssh/patches/010-better_fzero-call-detection.patch b/net/openssh/patches/010-better_fzero-call-detection.patch
new file mode 100644
index 000000000..ab4b2dabd
--- /dev/null
+++ b/net/openssh/patches/010-better_fzero-call-detection.patch
@@ -0,0 +1,52 @@
+From 1036d77b34a5fa15e56f516b81b9928006848cbd Mon Sep 17 00:00:00 2001
+From: Damien Miller <djm@mindrot.org>
+Date: Fri, 22 Dec 2023 17:56:26 +1100
+Subject: [PATCH] better detection of broken -fzero-call-used-regs
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+gcc 13.2.0 on ppc64le refuses to compile some function, including
+cipher.c:compression_alg_list() with an error:
+
+> sorry, unimplemented: argument ‘used’ is not supportedcw
+> for ‘-fzero-call-used-regs’ on this target
+
+This extends the autoconf will-it-work test with a similarly-
+structured function that seems to catch this.
+
+Spotted/tested by Colin Watson; bz3645
+---
+ m4/openssh.m4 | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+--- a/m4/openssh.m4
++++ b/m4/openssh.m4
+@@ -20,18 +20,24 @@ char *f2(char *s, ...) {
+ va_end(args);
+ return strdup(ret);
+ }
++const char *f3(int s) {
++ return s ? "good" : "gooder";
++}
+ int main(int argc, char **argv) {
+- (void)argv;
+ char b[256], *cp;
++ const char *s;
+ /* Some math to catch -ftrapv problems in the toolchain */
+ int i = 123 * argc, j = 456 + argc, k = 789 - argc;
+ float l = i * 2.1;
+ double m = l / 0.5;
+ long long int n = argc * 12345LL, o = 12345LL * (long long int)argc;
++ (void)argv;
+ f(1);
+- snprintf(b, sizeof b, "%d %d %d %f %f %lld %lld\n", i,j,k,l,m,n,o);
++ s = f3(f(2));
++ snprintf(b, sizeof b, "%d %d %d %f %f %lld %lld %s\n", i,j,k,l,m,n,o,s);
+ if (write(1, b, 0) == -1) exit(0);
+- cp = f2("%d %d %d %f %f %lld %lld\n", i,j,k,l,m,n,o);
++ cp = f2("%d %d %d %f %f %lld %lld %s\n", i,j,k,l,m,n,o,s);
++ if (write(1, cp, 0) == -1) exit(0);
+ free(cp);
+ /*
+ * Test fallthrough behaviour. clang 10's -Wimplicit-fallthrough does