aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2015-11-01 14:38:52 +0800
committerJeffery To <jeffery.to@gmail.com>2015-11-01 14:38:52 +0800
commita69543b51e4542a8d5e4c42614d7e294476eeaad (patch)
treeba60900cfa375bd561d47a0d17727c15473a1b99
parent35ae47a44c9a4044647689ea1360fe5b6f2a90c9 (diff)
python-crypto: let the KeyError bubble up instead of manually throwing an AssertionError
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python-crypto/patches/002-fix-endianness-detect.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/lang/python-crypto/patches/002-fix-endianness-detect.patch b/lang/python-crypto/patches/002-fix-endianness-detect.patch
index fd3a656fd..baed012bf 100644
--- a/lang/python-crypto/patches/002-fix-endianness-detect.patch
+++ b/lang/python-crypto/patches/002-fix-endianness-detect.patch
@@ -1,15 +1,13 @@
---- a/setup.py 2015-10-30 23:30:22.334127083 +0800
-+++ b/setup.py 2015-10-30 23:33:03.856098660 +0800
-@@ -100,6 +100,12 @@
+--- a/setup.py
++++ b/setup.py
+@@ -100,6 +100,10 @@
w(kwd.get("end", "\n"))
def endianness_macro():
-+ if "CONFIG_BIG_ENDIAN" in os.environ:
-+ if os.environ["CONFIG_BIG_ENDIAN"] == "y":
-+ return ('PCT_BIG_ENDIAN', 1)
-+ else:
-+ return ('PCT_LITTLE_ENDIAN', 1)
-+ raise AssertionError("CONFIG_BIG_ENDIAN environment variable missing")
++ if os.environ["CONFIG_BIG_ENDIAN"] == "y":
++ return ('PCT_BIG_ENDIAN', 1)
++ else:
++ return ('PCT_LITTLE_ENDIAN', 1)
s = struct.pack("@I", 0x33221100)
if s == "\x00\x11\x22\x33".encode(): # little endian
return ('PCT_LITTLE_ENDIAN', 1)