aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-03-07 15:04:52 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-07 15:08:53 +0100
commita5e40ac639739e4a946aef92a33565912a6159ae (patch)
tree0b60a18c173adcea3251d3340c512418e430774c
parent8e370c886fe1b219e06c0db6db32f562c4c322f7 (diff)
libiio: bump to latest release v0.19
While at it making it as well kernel 5.4 compatible by backporting upstream patch which synchronizes channel types and modifier lists in the headers. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--libs/libiio/Makefile4
-rw-r--r--libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch80
2 files changed, 82 insertions, 2 deletions
diff --git a/libs/libiio/Makefile b/libs/libiio/Makefile
index b1260936a..09259be70 100644
--- a/libs/libiio/Makefile
+++ b/libs/libiio/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiio
-PKG_VERSION:=0.18
+PKG_VERSION:=0.19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/analogdevicesinc/libiio/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=bc2c5299974b65cfe9aa4a06d8c74d7651594e026bce416db48a2c5aa7ba2554
+PKG_HASH:=81c414d5c47b715d9bc9275b9fabbfd9e9483e60c035f3001b5977932049595d
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING.txt
diff --git a/libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch b/libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch
new file mode 100644
index 000000000..96630bea4
--- /dev/null
+++ b/libs/libiio/patches/0001-Update-channel-type-and-modifier-lists.patch
@@ -0,0 +1,80 @@
+From 98ba73179f6db323b68a8d59e90c2d7c39a16736 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Tue, 3 Mar 2020 18:27:42 +0100
+Subject: [PATCH] Update channel type and modifier lists
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Update the channel type and modifier lists against Linux 5.4.22.
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ channel.c | 10 ++++++++++
+ iio.h | 10 ++++++++++
+ 2 files changed, 20 insertions(+)
+
+diff --git a/channel.c b/channel.c
+index 302592dfc764..407ce632fcc7 100644
+--- a/channel.c
++++ b/channel.c
+@@ -56,6 +56,9 @@ static const char * const iio_chan_type_name_spec[] = {
+ [IIO_COUNT] = "count",
+ [IIO_INDEX] = "index",
+ [IIO_GRAVITY] = "gravity",
++ [IIO_POSITIONRELATIVE] = "positionrelative",
++ [IIO_PHASE] = "phase",
++ [IIO_MASSCONCENTRATION] = "massconcentration",
+ };
+
+ static const char * const modifier_names[] = {
+@@ -79,6 +82,7 @@ static const char * const modifier_names[] = {
+ [IIO_MOD_LIGHT_GREEN] = "green",
+ [IIO_MOD_LIGHT_BLUE] = "blue",
+ [IIO_MOD_LIGHT_UV] = "uv",
++ [IIO_MOD_LIGHT_DUV] = "duv",
+ [IIO_MOD_QUATERNION] = "quaternion",
+ [IIO_MOD_TEMP_AMBIENT] = "ambient",
+ [IIO_MOD_TEMP_OBJECT] = "object",
+@@ -94,7 +98,13 @@ static const char * const modifier_names[] = {
+ [IIO_MOD_I] = "i",
+ [IIO_MOD_Q] = "q",
+ [IIO_MOD_CO2] = "co2",
++ [IIO_MOD_ETHANOL] = "ethanol",
++ [IIO_MOD_H2] = "h2",
+ [IIO_MOD_VOC] = "voc",
++ [IIO_MOD_PM1] = "pm1",
++ [IIO_MOD_PM2P5] = "pm2p5",
++ [IIO_MOD_PM4] = "pm4",
++ [IIO_MOD_PM10] = "pm10",
+ };
+
+ /*
+diff --git a/iio.h b/iio.h
+index 5c11fcefe5c2..5afc28ea0197 100644
+--- a/iio.h
++++ b/iio.h
+@@ -125,6 +125,9 @@ enum iio_chan_type {
+ IIO_COUNT,
+ IIO_INDEX,
+ IIO_GRAVITY,
++ IIO_POSITIONRELATIVE,
++ IIO_PHASE,
++ IIO_MASSCONCENTRATION,
+ IIO_CHAN_TYPE_UNKNOWN = INT_MAX
+ };
+
+@@ -173,6 +176,13 @@ enum iio_modifier {
+ IIO_MOD_CO2,
+ IIO_MOD_VOC,
+ IIO_MOD_LIGHT_UV,
++ IIO_MOD_LIGHT_DUV,
++ IIO_MOD_PM1,
++ IIO_MOD_PM2P5,
++ IIO_MOD_PM4,
++ IIO_MOD_PM10,
++ IIO_MOD_ETHANOL,
++ IIO_MOD_H2,
+ };
+
+ /* ---------------------------------------------------------------------------*/