aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2021-06-16 22:08:01 -0500
committerW. Michael Petullo <mike@flyn.org>2021-06-16 22:08:01 -0500
commita41556af4f2fb5c79b3a7902b4f3ca3b81644920 (patch)
tree2ef079d110aee2337782f3b8d4754824fdecee9d
parentbda9ae631ea4ea96af2fd73ad207ee3757017743 (diff)
podman: change permissions on /usr/share/containers/seccomp.json
Running podman as users other than root seems to require that those users can read /usr/share/containers/seccomp.json. This change sets the permissions on that file to match those used on Fedora. Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--utils/podman/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/podman/Makefile b/utils/podman/Makefile
index 6710ac59d..a7976df24 100644
--- a/utils/podman/Makefile
+++ b/utils/podman/Makefile
@@ -100,7 +100,7 @@ define Package/podman/install
$(INSTALL_DIR) $(1)/etc/cni/net.d
$(INSTALL_CONF) $(PKG_BUILD_DIR)/cni/87-podman-bridge.conflist $(1)/etc/cni/net.d/
$(INSTALL_DIR) $(1)/usr/share/containers
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/vendor/github.com/containers/common/pkg/seccomp/seccomp.json $(1)/usr/share/containers/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/vendor/github.com/containers/common/pkg/seccomp/seccomp.json $(1)/usr/share/containers/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/podman.init $(1)/etc/init.d/podman
$(SED) 's/driver = \"\"/driver = \"overlay\"/g' $(1)/etc/containers/storage.conf