aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-03-14 23:10:52 +0200
committerGitHub <noreply@github.com>2018-03-14 23:10:52 +0200
commita296a374c63d5316e167bf0845fbea704995c017 (patch)
treeb14dddc8d29baeab3231655bf0d81fee24ff8ea9
parent343f42d5f3e34775238926b5d8b707e1ddba88f2 (diff)
parentb6973e5deb5a3172f303f4717e039bcb79c49469 (diff)
Merge pull request #5758 from commodo/python-fix-macos-x-build
python,python3: attempt to fix Mac OS X host build issues
-rw-r--r--lang/python/python/Makefile7
-rw-r--r--lang/python/python3/Makefile7
2 files changed, 10 insertions, 4 deletions
diff --git a/lang/python/python/Makefile b/lang/python/python/Makefile
index c70c486e8..0948e3500 100644
--- a/lang/python/python/Makefile
+++ b/lang/python/python/Makefile
@@ -268,9 +268,13 @@ define PyPackage/python/filespec
endef
HOST_LDFLAGS += \
- -Wl,--no-as-needed -lrt \
$$$$(pkg-config --static --libs libcrypto libssl)
+ifeq ($(HOST_OS),Linux)
+HOST_LDFLAGS += \
+ -Wl,--no-as-needed -lrt
+endif
+
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
@@ -278,7 +282,6 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(HOST_PYTHON_DIR) \
--exec-prefix=$(HOST_PYTHON_DIR) \
--with-system-expat=$(STAGING_DIR_HOSTPKG) \
- --with-system-ffi=no \
--with-ensurepip=install \
CONFIG_SITE=
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index cd97378ce..85952c298 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -264,9 +264,13 @@ define Py3Package/python3/filespec
endef
HOST_LDFLAGS += \
- -Wl,--no-as-needed -lrt \
$$$$(pkg-config --static --libs libcrypto libssl)
+ifeq ($(HOST_OS),Linux)
+HOST_LDFLAGS += \
+ -Wl,--no-as-needed -lrt
+endif
+
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
@@ -274,7 +278,6 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(HOST_PYTHON3_DIR) \
--exec-prefix=$(HOST_PYTHON3_DIR) \
--with-system-expat=$(STAGING_DIR_HOSTPKG) \
- --with-system-ffi=no \
--with-ensurepip=install \
CONFIG_SITE=