aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leonard <antonlacon@gmail.com>2015-12-30 13:13:03 -0800
committerIan Leonard <antonlacon@gmail.com>2016-09-06 22:38:58 -0700
commita0310dc36f05454f7a66b4db67ac943fdeeb20a7 (patch)
treedf43947ad9d2b16d5fa7bf2866439b02a45b58a3
parent6695e1be7e4a2ed4e3db32bbbecf9dfaee9c3cff (diff)
libopus: update to 1.1.3
Update to 1.1.3 and use integer functions when no hardware fpu present. Signed-off-by: Ian Leonard <antonlacon@gmail.com>
-rw-r--r--libs/opus/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index ed64c3ed5..9d74464b9 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2014-2015 OpenWrt.org
+# Copyright (C) 2014-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=opus
-PKG_VERSION:=1.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.3
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
-PKG_MD5SUM:=c5a8cf7c0b066759542bc4ca46817ac6
+PKG_MD5SUM:=32bbb6b557fe1b6066adc0ae1f08b629
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/libopus
SECTION:=libs
CATEGORY:=Libraries
- TITLE:=OPUS Codec
+ TITLE:=OPUS Audio Codec
URL:=http://opus-codec.org/
endef
@@ -40,6 +40,11 @@ CONFIGURE_ARGS+= \
--disable-doc \
--disable-extra-programs
+ifeq ($(CONFIG_SOFT_FLOAT),y)
+ CONFIGURE_ARGS+= \
+ --enable-fixed-point
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/