aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-01 18:43:02 -0700
committerRosen Penev <rosenp@gmail.com>2021-06-02 20:21:40 -0700
commita02d79327bdaa2bb80a884ffce5f0ec71bf709d8 (patch)
tree7fdbc5c20f8e7ceb99e36cb73d18394e55def901
parent65a346bc51037d03f05ec9ee8f2beb303548577c (diff)
tang: update to 10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/tang/Makefile6
-rw-r--r--utils/tang/patches/010-http.patch11
2 files changed, 14 insertions, 3 deletions
diff --git a/utils/tang/Makefile b/utils/tang/Makefile
index be0a796a6..e2a1c6ba1 100644
--- a/utils/tang/Makefile
+++ b/utils/tang/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tang
-PKG_VERSION:=8
-PKG_RELEASE:=1
+PKG_VERSION:=10
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/latchset/$(PKG_NAME)/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=03958bf27c24aa9892f6138d287d39bcc149e7ad72163c27b529aa3c6b066ede
+PKG_HASH:=082f17e031708ab5e2f88c9b767d228bcf92a0d089fdb164d4ae93845cbd2a48
PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/utils/tang/patches/010-http.patch b/utils/tang/patches/010-http.patch
new file mode 100644
index 000000000..12ca66684
--- /dev/null
+++ b/utils/tang/patches/010-http.patch
@@ -0,0 +1,11 @@
+--- a/meson.build
++++ b/meson.build
+@@ -54,7 +54,7 @@ compiler = meson.get_compiler('c')
+ if not compiler.has_header('http_parser.h',args : '-I/usr/local/include')
+ error('http-parser devel files not found.')
+ endif
+-http_parser = compiler.find_library('http_parser',dirs:['/usr/lib','/usr/local/lib'])
++http_parser = compiler.find_library('http_parser')
+
+ licenses = ['COPYING']
+ libexecbins = []