aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-08 00:28:57 +0300
committerRosen Penev <rosenp@gmail.com>2022-01-11 16:25:33 -0800
commita00735ec8c974f8dd3326ed241cfb99cec0d48ea (patch)
treefa97968c14a77d1174596875f6c9a94f4342ad56
parent6754a2c80a0cab7aadae12d7444463f0c5318e29 (diff)
luasql: fix build on macos
luasql ./config scripts checks `uname -s` output and changes LIB_OPTION from '-static' to macos specific if detected OS is Darwin. These flags are not compatible with GCC OpenWrt is always Linux, this patch removes Darwin specific stuff from compilation flags Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
-rw-r--r--lang/luasql/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/luasql/Makefile b/lang/luasql/Makefile
index baea0c166..8c35df921 100644
--- a/lang/luasql/Makefile
+++ b/lang/luasql/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luasql
PKG_VERSION:=2.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/keplerproject/luasql/tar.gz/v$(PKG_VERSION)?
@@ -94,6 +94,7 @@ ifeq ($(BUILD_VARIANT),sqlite3)
endif
MAKE_FLAGS += \
+ LIB_OPTION="-shared" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
$(BUILD_VARIANT)