aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-04-21 10:22:27 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2015-04-21 10:22:27 +0300
commit9fc15af80aaaa6f05c16de5b9c0a22ae81cafeec (patch)
treeb5dfe5bb39b6828d0d18d3cf0fa0ed50cac50837
parent6e042a2b22f6d1efe7cba71565a2ced6a311fdeb (diff)
python3: do not prefer ncursesw over ncurses
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python3/patches/011-do-not-prefer-ncursesw.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/lang/python3/patches/011-do-not-prefer-ncursesw.patch b/lang/python3/patches/011-do-not-prefer-ncursesw.patch
new file mode 100644
index 000000000..c02322534
--- /dev/null
+++ b/lang/python3/patches/011-do-not-prefer-ncursesw.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.py b/setup.py
+index 2779658..b6d3d61 100644
+--- a/setup.py
++++ b/setup.py
+@@ -693,8 +693,8 @@ class PyBuildExt(build_ext):
+ # use the same library for the readline and curses modules.
+ if 'curses' in readline_termcap_library:
+ curses_library = readline_termcap_library
+- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+- curses_library = 'ncursesw'
++ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
++ # curses_library = 'ncursesw'
+ elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
+ curses_library = 'ncurses'
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):