aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-12-31 13:36:26 +0800
committerTianling Shen <cnsztl@gmail.com>2024-01-01 11:04:28 +0800
commit9f01010958b9f57ef51903f69c7223eaefabf139 (patch)
tree0040aefac97dabb0d799e485bb830e66520eb81a
parentdc39565a5699b4012d7a9ffcd173a5f43d748c4d (diff)
rust: unexport host sccache env variable
Users might configure their own env variables on the host, and sometimes it can lead build failure or unexpected behavior. Fixes: #22889 Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
-rw-r--r--lang/rust/Makefile2
-rw-r--r--lang/rust/rust-values.mk6
2 files changed, 7 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index ba322cf1d..b8f03ae94 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rust
PKG_VERSION:=1.74.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=rustc-$(PKG_VERSION)-src.tar.gz
PKG_SOURCE_URL:=https://static.rust-lang.org/dist/
diff --git a/lang/rust/rust-values.mk b/lang/rust/rust-values.mk
index 7a4d1fcf8..534aaa02a 100644
--- a/lang/rust/rust-values.mk
+++ b/lang/rust/rust-values.mk
@@ -2,6 +2,12 @@
#
# Copyright (C) 2023 Luca Barbato and Donald Hoskins
+# Clear environment variables which should be handled internally,
+# as users might configure their own env on the host
+
+# CCache
+unexport RUSTC_WRAPPER
+
# Rust Environmental Vars
RUSTC_HOST_SUFFIX:=$(word 4, $(subst -, ,$(GNU_HOST_NAME)))
RUSTC_HOST_ARCH:=$(HOST_ARCH)-unknown-linux-$(RUSTC_HOST_SUFFIX)