aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEduardo Abinader <eduardoabinader@gmail.com>2018-11-10 00:11:50 +0100
committerEduardo Abinader <eduardoabinader@gmail.com>2018-11-10 10:25:38 +0100
commit9eba4f5801a77c131fac01d65c5d719544b2f9d1 (patch)
treeed3a63bd10e6966dc451492ab54e4dbadec376c1
parent52575dbc109687264e21962f9e31002ad6ce46d5 (diff)
opusfile: required by opus-tools 0.2
new dep on opus-tools e9bbfacf0a1bbade70005fa730cc50e838baaa32 Signed-off-by: Eduardo Abinader <eduardoabinader@gmail.com>
1 files changed, 54 insertions, 0 deletions
diff --git a/libs/opusfile/Makefile b/libs/opusfile/Makefile
new file mode 100644
index 000000000..eb8475c96
--- /dev/null
+++ b/libs/opusfile/Makefile
@@ -0,0 +1,54 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=opusfile
+PKG_VERSION:=0.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
+PKG_HASH:=74ce9b6cf4da103133e7b5c95df810ceb7195471e1162ed57af415fabf5603bf
+
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Eduardo Abinader <eduardoabinader@gmail.com>
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libopusfile
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libogg +libopus +libopenssl
+ TITLE:=OPUS file library
+ URL:=http://opus-codec.org/
+endef
+
+define Package/libopusfile/description
+ The opusfile library provides seeking, decode, and playback of Opus streams in the Ogg container (.opus files)
+endef
+
+CONFIGURE_ARGS += \
+ --without-flac \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/opusfile.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/opusurl.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libopusfile/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libopusfile))