aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-25 13:19:48 +0800
committerJeffery To <jeffery.to@gmail.com>2023-05-25 15:01:28 +0800
commit9e95dff9ac461d7bcd6fc053292c975241d11448 (patch)
treee89103c988066683c5874283212251878dbf511e
parent6b8340d3cad7a6bd36aa21c93de82c47bf871c33 (diff)
python-packages: Remove __PYVENV_LAUNCHER__ environment variable
Setting __PYVENV_LAUNCHER__ for Python package builds was added in a91a992abb1fe9b7c4e4e5d11532dbf18c5b213d, but neither the commit message nor the pull request[1] explain its purpose in detail. My guess is this was done to set the shebang for installed Python scripts. We now have a Makefile recipe to set the shebang, so it would be unnecessary to set this variable for this purpose. It appears that Python 3.11 has changed the handling of this (internal) environment variable, and setting it appears to be causing build errors for all Python packages. This removes setting __PYVENV_LAUNCHER__ for Python package builds. [1]: https://github.com/openwrt/packages/pull/525 Fixes: https://github.com/openwrt/packages/issues/21162 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python3-package.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index d5d4f8a0f..d07cec174 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -39,7 +39,6 @@ PYTHON3_VARS = \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PYTHON3_INC_DIR)" \
LDFLAGS="$(TARGET_LDFLAGS) -lpython$(PYTHON3_VERSION)" \
_PYTHON_HOST_PLATFORM="$(_PYTHON_HOST_PLATFORM)" \
- __PYVENV_LAUNCHER__="/usr/bin/$(PYTHON3)" \
PYTHONPATH="$(PYTHON3PATH)" \
PYTHONDONTWRITEBYTECODE=1 \
_python_sysroot="$(STAGING_DIR)" \