aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <alex@shruggie.ro>2023-07-16 13:58:54 +0300
committerGitHub <noreply@github.com>2023-07-16 13:58:54 +0300
commit9e8e451307ffc51dfbcc79eba108e200ca555ae6 (patch)
tree24a49ddad474b319ae863fbc8cb28f357c7029f9
parent1c14eb6d8ced8bc49825bc109984a8b6715c1a08 (diff)
parent11ebe528df81ca9e96054cc63b3984cc202f6ff8 (diff)
Merge pull request #21568 from commodo/python-updates1
pillow, pymysql, requests: bump versions
-rw-r--r--lang/python/pillow/Makefile8
-rw-r--r--lang/python/pillow/patches/001-remove-setuptools-version-limit.patch11
-rw-r--r--lang/python/pymysql/Makefile4
-rw-r--r--lang/python/python-requests/Makefile4
4 files changed, 20 insertions, 7 deletions
diff --git a/lang/python/pillow/Makefile b/lang/python/pillow/Makefile
index 753ceec25..c974723a9 100644
--- a/lang/python/pillow/Makefile
+++ b/lang/python/pillow/Makefile
@@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pillow
-PKG_VERSION:=9.5.0
-PKG_RELEASE:=2
+PKG_VERSION:=10.0.0
+PKG_RELEASE:=1
PYPI_NAME:=Pillow
-PKG_HASH:=bf548479d336726d7a0eceb6e767e179fbde37833ae42794602631a070d630f1
+PKG_HASH:=9c82b5b3e043c7af0d95792d0d20ccf68f61a1fec6b3530e718b688422727396
+
+PKG_BUILD_DEPENDS:=python-setuptools-scm/host
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=HPND
diff --git a/lang/python/pillow/patches/001-remove-setuptools-version-limit.patch b/lang/python/pillow/patches/001-remove-setuptools-version-limit.patch
new file mode 100644
index 000000000..3dc07d992
--- /dev/null
+++ b/lang/python/pillow/patches/001-remove-setuptools-version-limit.patch
@@ -0,0 +1,11 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,7 +1,7 @@
+ [build-system]
+ build-backend = "backend"
+ requires = [
+- "setuptools>=67.8",
++ "setuptools",
+ "wheel",
+ ]
+ backend-path = [
diff --git a/lang/python/pymysql/Makefile b/lang/python/pymysql/Makefile
index 469efeaf8..d5187bd57 100644
--- a/lang/python/pymysql/Makefile
+++ b/lang/python/pymysql/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pymysql
-PKG_VERSION:=1.0.2
+PKG_VERSION:=1.1.0
PKG_RELEASE:=1
PYPI_NAME:=PyMySQL
-PKG_HASH:=816927a350f38d56072aeca5dfb10221fe1dc653745853d30a216637f5d7ad36
+PKG_HASH:=4f13a7df8bf36a51e81dd9f3605fede45a4878fe02f9236349fd82a3f0612f96
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=MIT
diff --git a/lang/python/python-requests/Makefile b/lang/python/python-requests/Makefile
index 8acc606d3..c6b156f16 100644
--- a/lang/python/python-requests/Makefile
+++ b/lang/python/python-requests/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-requests
-PKG_VERSION:=2.30.0
+PKG_VERSION:=2.31.0
PKG_RELEASE:=1
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>, Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:python-requests:requests
PYPI_NAME:=requests
-PKG_HASH:=239d7d4458afcb28a692cdd298d87542235f4ca8d36d03a15bfc128a6559a2f4
+PKG_HASH:=942c5a758f98d790eaed1a29cb6eefc7ffb0d1cf7af05c3d2791656dbd6ad1e1
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk