aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-24 13:02:57 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-24 12:12:49 -0800
commit9e7739057f0e1621675a589bc7c2a7a080c97a20 (patch)
treeb7bef062408f00bb34e8b7b689861c3762bacd29
parentacc4d9058e98254b1c8dbd9a86347242dfc9912c (diff)
htpdate: update to 1.3.7
- Switch package URLs to HTTPS - Use .gz for source archive since .xz is no longer available - Remove upstreamed patches Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/htpdate/Makefile13
-rw-r--r--net/htpdate/patches/100-adjtimex.patch20
-rw-r--r--net/htpdate/patches/101-daemon-run-in-foreground.patch40
3 files changed, 6 insertions, 67 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index acb0b0d7a..7fbccf032 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=htpdate
-PKG_VERSION:=1.1.1
-PKG_RELEASE:=5
+PKG_VERSION:=1.3.7
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://www.vervest.org/htp/archive/c/
-PKG_HASH:=0d75f91cb61f8869c8298d198fa52b9a139ae505b366e9d4d331af8bc1c04880
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://www.vervest.org/htp/archive/c/
+PKG_HASH:=88c52fe475308ee95f560fd7cf68c75bc6e9a6abf56be7fed203a7f762fe7ab2
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=
@@ -25,7 +25,7 @@ define Package/htpdate
SECTION:=net
CATEGORY:=Network
TITLE:=an HTP (Hypertext Time Protocol) implementation
- URL:=http://www.vervest.com/htp/
+ URL:=https://www.vervest.org/htp/
MAINTAINER:=Tijs Van Buggenhout <tvbuggen@netzerk.be>, \
Marcin Jurkowski <marcin1j@gmail.com>
endef
@@ -58,4 +58,3 @@ define Package/htpdate/install
endef
$(eval $(call BuildPackage,htpdate))
-
diff --git a/net/htpdate/patches/100-adjtimex.patch b/net/htpdate/patches/100-adjtimex.patch
deleted file mode 100644
index ec7c8a98e..000000000
--- a/net/htpdate/patches/100-adjtimex.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/htpdate.c
-+++ b/htpdate.c
-@@ -359,7 +359,7 @@ static int htpdate_adjtimex( double drif
-
- /* Read current kernel frequency */
- tmx.modes = 0;
-- ntp_adjtime(&tmx);
-+ adjtimex(&tmx);
-
- /* Calculate new frequency */
- freq = (long)(65536e6 * drift);
-@@ -377,7 +377,7 @@ static int htpdate_adjtimex( double drif
- printlog( 1, "seteuid()" );
- exit(1);
- } else {
-- return( ntp_adjtime(&tmx) );
-+ return( adjtimex(&tmx) );
- }
-
- }
diff --git a/net/htpdate/patches/101-daemon-run-in-foreground.patch b/net/htpdate/patches/101-daemon-run-in-foreground.patch
deleted file mode 100644
index a68365aeb..000000000
--- a/net/htpdate/patches/101-daemon-run-in-foreground.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/htpdate.c
-+++ b/htpdate.c
-@@ -395,6 +395,7 @@ Usage: htpdate [-046abdhlqstxD] [-i pid
- -b burst mode\n\
- -d debug mode\n\
- -D daemon mode\n\
-+ -f run in foreground\n\
- -h help\n\
- -i pid file\n\
- -l use syslog for output\n\
-@@ -510,7 +511,7 @@ int main( int argc, char *argv[] ) {
-
-
- /* Parse the command line switches and arguments */
-- while ( (param = getopt(argc, argv, "046abdhi:lm:p:qstu:xDM:P:") ) != -1)
-+ while ( (param = getopt(argc, argv, "046abdhi:lm:p:qstu:xDfM:P:") ) != -1)
- switch( param ) {
-
- case '0': /* HTTP/1.0 */
-@@ -593,6 +594,9 @@ int main( int argc, char *argv[] ) {
- daemonize = 1;
- logmode = 1;
- break;
-+ case 'f': /* run in foreground */
-+ daemonize = 2;
-+ break;
- case 'M': /* maximum poll interval */
- if ( ( maxsleep = atoi(optarg) ) <= 0 ) {
- fputs( "Invalid sleep time\n", stderr );
-@@ -631,7 +635,9 @@ int main( int argc, char *argv[] ) {
-
- /* Run as a daemonize when -D is set */
- if ( daemonize ) {
-- runasdaemon( pidfile );
-+ if ( daemonize == 1 ) {
-+ runasdaemon( pidfile );
-+ }
- /* Query only mode doesn't exist in daemon mode */
- if ( !setmode )
- setmode = 1;