aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2022-04-06 10:17:19 +0900
committerRosen Penev <rosenp@gmail.com>2022-04-16 11:01:53 -0700
commit9dc5f7e3288fa86d62e5efcc53f1be551440f772 (patch)
treebe27bdd3e1237a697ec3ac1cb1761e0accb98c37
parentd2109d23f8a6f677665274f55b90cdb739425e89 (diff)
node-serialport: Support for npm@8
With the upgrade of node.js to version 16, the npm version will also change to version 8. This fix is to support npm@8. npm@6 can also build without problems. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
-rw-r--r--lang/node-serialport/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index 7988b0865..ee1d6e404 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=9.0.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
@@ -45,9 +45,9 @@ NODEJS_CPU:=$(subst powerpc,ppc,$(subst aarch64,arm64,$(subst x86_64,x64,$(subst
TMPNPM:=$(shell mktemp -u XXXXXXXXXX)
TARGET_CFLAGS+=$(FPIC)
+TARGET_CPPFLAGS+=$(FPIC)
-define Build/Compile
- $(MAKE_VARS) \
+NPM_FLAGS=$(MAKE_VARS) \
$(MAKE_FLAGS) \
npm_config_arch=$(NODEJS_CPU) \
npm_config_target_arch=$(NODEJS_CPU) \
@@ -55,8 +55,11 @@ define Build/Compile
npm_config_nodedir=$(STAGING_DIR)/usr/ \
npm_config_prefix=$(PKG_INSTALL_DIR)/usr/ \
npm_config_cache=$(TMP_DIR)/npm-cache-$(TMPNPM) \
- npm_config_tmp=$(TMP_DIR)/npm-tmp-$(TMPNPM) \
- npm install -g $(PKG_BUILD_DIR)
+ npm_config_tmp=$(TMP_DIR)/npm-tmp-$(TMPNPM)
+
+define Build/Compile
+ $(NPM_FLAGS) npm i -g --production $(PKG_BUILD_DIR)
+ $(NPM_FLAGS) npm i --production --prefix=$(PKG_BUILD_DIR) --target_arch=$(NODEJS_CPU) --prefer-dedupe
rm -rf $(TMP_DIR)/npm-tmp-$(TMPNPM)
rm -rf $(TMP_DIR)/npm-cache-$(TMPNPM)
endef