aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMislav Novakovic <mislav.novakovic@sartura.hr>2018-11-28 14:23:52 +0100
committerMislav Novakovic <mislav.novakovic@sartura.hr>2018-11-28 14:23:52 +0100
commit9cb6d07cabec470648bbdbdd628ca743d082a811 (patch)
tree5d5e803372d6a3b3012096f545fa5dc76cd77853
parent583977b9539185612f91f1a820431ecfc597468b (diff)
Netopeer2: update to 0.7-r1
Signed-off-by: Mislav Novakovic <mislav.novakovic@sartura.hr>
-rw-r--r--net/Netopeer2/Makefile4
-rw-r--r--net/Netopeer2/patches/001-fix-for-cmake-build9
2 files changed, 7 insertions, 6 deletions
diff --git a/net/Netopeer2/Makefile b/net/Netopeer2/Makefile
index 81c21cd93..f61ddcc66 100644
--- a/net/Netopeer2/Makefile
+++ b/net/Netopeer2/Makefile
@@ -10,14 +10,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=Netopeer2
-PKG_VERSION:=0.6-r1
+PKG_VERSION:=0.7-r1
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=5f38db43f6021e389cf1f3c5c70e432586d8ba7f2d64ed5bd2bea8c7ea6b39e6
+PKG_HASH:=040013d1e315c62c496b704475665165578c374ffb387cbbff422cf8898d3a12
CMAKE_INSTALL:=1
diff --git a/net/Netopeer2/patches/001-fix-for-cmake-build b/net/Netopeer2/patches/001-fix-for-cmake-build
index dad54a440..3dae3caa5 100644
--- a/net/Netopeer2/patches/001-fix-for-cmake-build
+++ b/net/Netopeer2/patches/001-fix-for-cmake-build
@@ -65,10 +65,11 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLis
project(netopeer2-server C)
include(GNUInstallDirs)
-@@ -176,7 +176,7 @@ if (ENABLE_CONFIGURATION)
- execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/model-install.sh)")
+@@ -204,7 +204,7 @@ if (ENABLE_CONFIGURATION)
+ execute_process(COMMAND ${PROJECT_BINARY_DIR}/model-install.sh)")
endif()
-
+
-add_custom_target(install-scripts-ide
+add_custom_target(install-scripts-ide-server
- scripts/model-install.sh
+ ${PROJECT_BINARY_DIR}/model-install.sh
+ )