aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2015-01-06 10:48:52 +0200
committerAlexandru Ardelean <aa@ocedo.com>2015-01-06 10:50:31 +0200
commit9b94e3cb6eab07e6ba44ca74ea5ffc19f39d0bd7 (patch)
treec12fe12d46e590eadef9378e6192b85954c0ae8a
parent591af75d2e62244ecd5270d1c6f0f2df9bff76f4 (diff)
python: trim all whitespaces for the operator in the filespec
That would allow for files (in filespecs) to be indented. As it is now, the files need to be added at the begginning of the line. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/files/python-package.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 9a999d4f0..71d500d1d 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -45,6 +45,7 @@ define PyPackage
@echo "$$$$$$$$$$(call shvar,PyPackage/$(1)/filespec)" | ( \
IFS='|'; \
while read fop fspec fperm; do \
+ fop=`echo "$$$$$$$$fop" | tr -d ' \t\n'`; \
if [ "$$$$$$$$fop" = "+" ]; then \
if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \