aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-27 12:31:02 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2024-02-27 23:45:41 +0200
commit9ad2c1fd97fbadf8d40835e3e7722fc1e7fc2e4f (patch)
tree94db6558efe74a12b6c534e3c74c9e02d61d5da5
parentdf9d076d600a3d02da198af4a625980ed0633d2a (diff)
openthread-br: fix build error on some platforms
On some builders the package was failing to build: ``` cp: cannot overwrite non-directory '[..]/var' with directory '[..]/var ``` Here we're moving the creation of /var/lib/thread into runtime script, which eliminates the error. Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/openthread-br/Makefile3
-rw-r--r--net/openthread-br/files/openthread-proto.sh1
2 files changed, 2 insertions, 2 deletions
diff --git a/net/openthread-br/Makefile b/net/openthread-br/Makefile
index 1b42cceee..35c3b969d 100644
--- a/net/openthread-br/Makefile
+++ b/net/openthread-br/Makefile
@@ -96,8 +96,7 @@ define Package/openthread-br/install
$(INSTALL_DIR) \
$(1)/etc/init.d \
$(1)/lib/netifd/proto \
- $(1)/usr/sbin \
- $(1)/var/lib/thread
+ $(1)/usr/sbin
$(INSTALL_BIN) ./files/openthread-proto.sh $(1)/lib/netifd/proto/openthread.sh
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
endef
diff --git a/net/openthread-br/files/openthread-proto.sh b/net/openthread-br/files/openthread-proto.sh
index 928bafe71..360786aaf 100644
--- a/net/openthread-br/files/openthread-proto.sh
+++ b/net/openthread-br/files/openthread-proto.sh
@@ -88,6 +88,7 @@ proto_openthread_setup() {
}
json_for_each_item proto_openthread_add_prefix prefix
+ mkdir -p /var/lib/thread
ubus call otbr threadstart || proto_openthread_setup_error "$interface" MISSING_UBUS_OBJ
$OTCTL netdata register