aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-03 13:36:42 -0700
committerGitHub <noreply@github.com>2020-08-03 13:36:42 -0700
commit9accec8e38bbd36091a3a555b626efd99fa16ed3 (patch)
tree4a607addfd2b08c10128e691920893e6df326c44
parenta7b526f032f52de4d55fdc202f73322a7f97e2d4 (diff)
parentf21c3b4e99533a054b417f18b2eeb1ca85b83f84 (diff)
Merge pull request #12998 from neheb/nloh2
nlohmannjson: build with meson
1 files changed, 9 insertions, 3 deletions
diff --git a/libs/nlohmannjson/Makefile b/libs/nlohmannjson/Makefile
index 08261c882..973bb63d6 100644
--- a/libs/nlohmannjson/Makefile
+++ b/libs/nlohmannjson/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nlohmannjson
PKG_VERSION:=3.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=json-$(PKG_VERSION).zip
PKG_SOURCE_URL:=https://codeload.github.com/nlohmann/json/zip/v$(PKG_VERSION)?
@@ -17,7 +17,11 @@ PKG_MAINTAINER:=Leonid Esman <leonid.esman@gmail.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE.MIT
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=meson/host
+
include $(INCLUDE_DIR)/package.mk
+include ../../devel/meson/meson.mk
define Package/nlohmannjson
SECTION:=libs
@@ -32,8 +36,10 @@ define Package/nlohmannjson/description
endef
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_BUILD_DIR)/include/nlohmann $(1)/usr/include
+ $(INSTALL_DIR) $(1)/usr/include/nlohmann
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/nlohmann/json.hpp $(1)/usr/include/nlohmann
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/nlohmann_json.pc $(1)/usr/lib/pkgconfig
endef
$(eval $(call BuildPackage,nlohmannjson))