aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2015-11-27 19:59:43 +0800
committerJeffery To <jeffery.to@gmail.com>2015-11-27 19:59:43 +0800
commit9a79d5f093d2594854c787bf925a3a62975d001f (patch)
treea20f28b3bbe5a331e0e990c8bda0f8d56510e2e0
parentc508fe103a585549855d1cafc1a15cdd63daf6fa (diff)
python-pycparser: add host compile/install
This depends on: - python-setuptools host install (#1985) - python-ply host install (#2032) Signed-off-by: Jeffery To <jeffery.to@gmail.com>
1 files changed, 13 insertions, 1 deletions
diff --git a/lang/python-pycparser/Makefile b/lang/python-pycparser/Makefile
index 68dc35ada..dce2225cc 100644
--- a/lang/python-pycparser/Makefile
+++ b/lang/python-pycparser/Makefile
@@ -16,13 +16,16 @@ PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pycparser
PKG_MD5SUM:=a2bc8d28c923b4fe2b2c3b4b51a4f935
PKG_BUILD_DEPENDS:=python python-setuptools
+HOST_BUILD_DEPENDS:=python/host python-setuptools/host python-ply/host
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
+$(call include_mk, python-host.mk)
define Package/python-pycparser
SECTION:=lang
@@ -45,8 +48,17 @@ define PyPackage/python-pycparser/filespec
endef
define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+ $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
endef
+define Host/Compile
+ $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOST)")
+endef
+
+define Host/Install
+endef
+
+$(eval $(call HostBuild))
+
$(eval $(call PyPackage,python-pycparser))
$(eval $(call BuildPackage,python-pycparser))