aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-10-01 10:46:02 +0200
committersbyx <steven@midlink.org>2014-10-01 10:46:02 +0200
commit999bc41dcedc7ced8b72ec2c20c4e54b1044a254 (patch)
tree1f38f0781c119b3fb1d28cfdf4859aadafa0ad89
parentd2d0d41dd9c1a237723c32cccdce7c1ba094b9d8 (diff)
parent13af207aaa89a6241435b9b6d8ee17890d5870ee (diff)
Merge pull request #387 from MikePetullo/dovecot
dovecot: add LDAP option
-rw-r--r--mail/dovecot/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 1f6becff7..da1f1d41f 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dovecot
SECTION:=mail
CATEGORY:=Mail
- DEPENDS:=+libopenssl +librt +zlib +libbz2 +libcap
+ DEPENDS:=+DOVECOT_LDAP:libopenldap +libopenssl +librt +zlib +libbz2 +libcap
TITLE:=An IMAP and POP3 daemon
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
URL:=http://www.dovecot.org/
@@ -37,6 +37,17 @@ define Package/dovecot/description
Dovecot is a program which provides POP3 and IMAP services.
endef
+define Package/dovecot/config
+ menu "Select dovecot build options"
+ depends on PACKAGE_dovecot
+ config DOVECOT_LDAP
+ bool "LDAP support"
+ default y
+ help
+ Implements LDAP support in dovecot.
+ endmenu
+endef
+
CONFIGURE_ARGS += \
--without-gssapi \
--without-pam \
@@ -45,6 +56,14 @@ CONFIGURE_ARGS += \
--without-lzma \
--without-lz4
+ifneq ($(strip $(CONFIG_DOVECOT_LDAP)),)
+ CONFIGURE_ARGS+= \
+ --with-ldap=yes
+else
+ CONFIGURE_ARGS+= \
+ --with-ldap=no
+endif
+
CONFIGURE_VARS += \
RPCGEN= \
i_cv_signed_size_t=no \