aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-05-14 12:08:46 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2018-05-14 12:11:00 +0300
commit995b48121eb0131913cde1585528db266e8caabf (patch)
tree6399e4aa81d7c3d192fd3fc7532869f54686dad3
parent20c6cec0c8b621155ecb311f417d2f97da339c8d (diff)
python,python3: remove `--ignore-installed` flag for host packages
This was copied over from python-packages, when support for installing packages host-side (via pip) was added. Based on the discussion on this commit: https://github.com/openwrt/packages/commit/612c53fc6c3d9ba2a57f7329baf055f1d59a9246 it was mentioned that removing this may add more benefit in terms of reducing build time, because packages won't get reinstalled every time. I'm not entirely sure about any potential side-effects of this, but it's worth trying it out. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/python-host.mk1
-rw-r--r--lang/python/python3-host.mk1
2 files changed, 0 insertions, 2 deletions
diff --git a/lang/python/python-host.mk b/lang/python/python-host.mk
index d4dc81fa9..eb58c557e 100644
--- a/lang/python/python-host.mk
+++ b/lang/python/python-host.mk
@@ -76,7 +76,6 @@ define host_python_pip_install
$(HOST_PYTHON_PIP) install \
--root=$(1) \
--prefix=$(2) \
- --ignore-installed \
$(3)
endef
diff --git a/lang/python/python3-host.mk b/lang/python/python3-host.mk
index 2a418d504..71ae09362 100644
--- a/lang/python/python3-host.mk
+++ b/lang/python/python3-host.mk
@@ -76,7 +76,6 @@ define host_python3_pip_install
$(HOST_PYTHON3_PIP) install \
--root=$(1) \
--prefix=$(2) \
- --ignore-installed \
$(3)
endef