aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-05-24 22:52:28 +0300
committerGitHub <noreply@github.com>2018-05-24 22:52:28 +0300
commit95c90276026afce40c2a15db424138717be6778f (patch)
tree424969ac31cc1f2194d4270e8f48baef0f4aa6ee
parent2bb5e0c7cb9f6c65c62477f0d209f1e8e8aae9f8 (diff)
parent0f9a536daf02d47bca67ac3bf1ae394bd9b844be (diff)
Merge pull request #6105 from cotequeiroz/libzdb_openssl-1.1
libzdb: add compatibility with openssl 1.1
-rw-r--r--libs/libzdb/Makefile2
-rw-r--r--libs/libzdb/patches/030-openssl-1.1.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index 1c172bd33..1034d041d 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libzdb
PKG_VERSION:=3.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/libs/libzdb/patches/030-openssl-1.1.patch b/libs/libzdb/patches/030-openssl-1.1.patch
new file mode 100644
index 000000000..b4f16a1ba
--- /dev/null
+++ b/libs/libzdb/patches/030-openssl-1.1.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_ARG_ENABLE([openssl],
+ else
+ openssl="true"
+ if test "x$enableval" = "xyes"; then
+- AC_CHECK_LIB([ssl], [SSL_library_init], [], [AC_MSG_ERROR([libssl not found])])
++ AC_CHECK_LIB([ssl], [SSL_CTX_new], [], [AC_MSG_ERROR([libssl not found])])
+ AC_CHECK_LIB([crypto], [SHA1_Init], [], [AC_MSG_ERROR([libcrypto not found])])
+ else
+ AC_MSG_CHECKING([for openssl in $enableval])