aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-04-22 22:58:28 -0600
committerGitHub <noreply@github.com>2023-04-22 22:58:28 -0600
commit9569c7c03f7dea42577b5b8b4d12a96695be45f5 (patch)
treeda124d0d2b0e0dbbeee05893d63bb0f50643f962
parentb607e193988e77a70fab96744cf36af353ebc804 (diff)
parent5f3840c765711577d9b39ff3908a2fa1c8522dd9 (diff)
Merge pull request #20857 from pprindeville/strongswan-drop-local_gateway
strongswan: local_gateway unused in swanctl.init
2 files changed, 1 insertions, 6 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 7f0e0c960..7b5275ba7 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
PKG_VERSION:=5.9.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
diff --git a/net/strongswan/files/swanctl.init b/net/strongswan/files/swanctl.init
index f32ca21c4..e05c7228d 100644
--- a/net/strongswan/files/swanctl.init
+++ b/net/strongswan/files/swanctl.init
@@ -418,7 +418,6 @@ config_connection() {
local enabled
local gateway
- local local_gateway
local local_sourceip
local local_ip
local remote_gateway
@@ -478,10 +477,6 @@ config_connection() {
[ "$gateway" = "any" ] && remote_gateway="%any" || remote_gateway="$gateway"
- local ipdest
- [ "$remote_gateway" = "%any" ] && ipdest="1.1.1.1" || ipdest="$remote_gateway"
- local_gateway=`ip -o route get $ipdest | awk '/ src / { gsub(/^.* src /,""); gsub(/ .*$/, ""); print $0}'`
-
if [ -n "$local_key" ]; then
[ "$(dirname "$local_key")" != "." ] && \
fatal "local_key $local_key can't be pathname"