aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-22 14:59:25 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-25 15:31:47 -0700
commit947899823248ce52efd345e3167bb506d8aa4b14 (patch)
tree0a0a2af18959a2a42264c6a32dcb2c2fdb198b6f
parent9c95fedca3d22b01c28dda7c72e70dfec9ca0f2e (diff)
ntfs-3g: do not install mount.ntfs into /usr/sbin
ntfs-3g does not include nor install a file like this. Cleaned up Makefile for consistency between packages. Added PKG_BUILD_PARALLEL for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/ntfs-3g/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/utils/ntfs-3g/Makefile b/utils/ntfs-3g/Makefile
index 19fbc1431..0c60ea184 100644
--- a/utils/ntfs-3g/Makefile
+++ b/utils/ntfs-3g/Makefile
@@ -6,34 +6,34 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ntfs-3g
-PKG_RELEASE:=2
-
PKG_VERSION:=2017.3.23
+PKG_RELEASE:=3
+
PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.tuxera.com/opensource/
PKG_HASH:=3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5
-PKG_LICENSE:=GPL-2.0 LGPL-2.0
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+PKG_LICENSE:=GPL-2.0-only LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING COPYING.LIB
PKG_CPE_ID:=cpe:/a:ntfs-3g:ntfs-3g
-PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
-
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
# release contains fuseext/int hint
PKG_RELEASE:=$(PKG_RELEASE)$(if $(CONFIG_PACKAGE_NTFS-3G_USE_LIBFUSE),-fuseext,-fuseint)
# define build dir, respect fuseext/int
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE)
+PKG_BUILD_DIR:= $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE)
include $(INCLUDE_DIR)/package.mk
define Package/ntfs-3g/common
SECTION:=utils
CATEGORY:=Utilities
- URL:=http://www.tuxera.com
+ URL:=https://www.tuxera.com
SUBMENU:=Filesystem
TITLE:=Stable Read/Write NTFS Driver
endef
@@ -161,7 +161,6 @@ define Package/ntfs-3g/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_INSTALL_DIR)/sbin/mount.ntfs-3g $(1)/sbin/
- $(CP) $(PKG_INSTALL_DIR)/sbin/mount.ntfs-3g $(1)/sbin/mount.ntfs
endef
define Package/ntfs-3g/postinst