aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-08-17 00:30:09 +0800
committerJeffery To <jeffery.to@gmail.com>2020-08-17 01:56:47 +0800
commit9277f74abddc8f91aad2cc97ec003ebe3c4c6c4c (patch)
tree122a0eb591b5c32176f8fa79778e275743847c4a
parentc158c02bc5f38cebff1bb523df9ca9b6bfc958cb (diff)
python-hyperlink: Update to 20.0.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-hyperlink/Makefile12
-rw-r--r--lang/python/python-hyperlink/patches/001-omit-tests.patch20
2 files changed, 18 insertions, 14 deletions
diff --git a/lang/python/python-hyperlink/Makefile b/lang/python/python-hyperlink/Makefile
index a91fa1cfe..eea6aa525 100644
--- a/lang/python/python-hyperlink/Makefile
+++ b/lang/python/python-hyperlink/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-hyperlink
-PKG_VERSION:=19.0.0
-PKG_RELEASE:=2
+PKG_VERSION:=20.0.1
+PKG_RELEASE:=1
PYPI_NAME:=hyperlink
-PKG_HASH:=4288e34705da077fada1111a24a0aa08bb1e76699c9ce49876af722441845654
+PKG_HASH:=47fcc7cd339c6cb2444463ec3277bdcfe142c8b1daf2160bdd52248deec815af
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
@@ -30,6 +30,7 @@ define Package/python3-hyperlink
URL:=https://github.com/python-hyper/hyperlink
DEPENDS:= \
+python3-light \
+ +python3-codecs \
+python3-idna
endef
@@ -39,6 +40,11 @@ on RFC 3986 and 3987, the Hyperlink URL makes working with both URIs and
IRIs easy.
endef
+define Py3Package/python3-hyperlink/filespec
++|$(PYTHON3_PKG_DIR)
+-|$(PYTHON3_PKG_DIR)/hyperlink/hypothesis.py
+endef
+
$(eval $(call Py3Package,python3-hyperlink))
$(eval $(call BuildPackage,python3-hyperlink))
$(eval $(call BuildPackage,python3-hyperlink-src))
diff --git a/lang/python/python-hyperlink/patches/001-omit-tests.patch b/lang/python/python-hyperlink/patches/001-omit-tests.patch
index cd0c8b800..e0ee3bddb 100644
--- a/lang/python/python-hyperlink/patches/001-omit-tests.patch
+++ b/lang/python/python-hyperlink/patches/001-omit-tests.patch
@@ -1,13 +1,11 @@
--- a/setup.py
+++ b/setup.py
-@@ -24,8 +24,9 @@ setup(name='hyperlink',
- author=__author__,
- author_email=__contact__,
- url=__url__,
-- packages=['hyperlink', 'hyperlink.test'],
-+ packages=['hyperlink'],
- include_package_data=True,
-+ exclude_package_data={'':['test/*']},
- zip_safe=False,
- license=__license__,
- platforms='any',
+@@ -25,7 +25,7 @@ setup(
+ author=__author__,
+ author_email=__contact__,
+ url=__url__,
+- packages=find_packages(where="src"),
++ packages=find_packages(where="src", exclude=["*.test", "*.test.*"]),
+ package_dir={"": "src"},
+ package_data=dict(hyperlink=["py.typed"]),
+ zip_safe=False,