aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2019-10-31 16:26:27 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2019-11-01 10:45:53 +0100
commit92398d28a53dcf87d5e30966c30119fd7c023ad4 (patch)
tree43eee42f264ae4d50537d48adc0ba736756d718e
parent5ae85b79526d4b0197d3581d349a2f7b6932bd52 (diff)
python-atomicwrites: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
1 files changed, 41 insertions, 0 deletions
diff --git a/lang/python/python-atomicwrites/Makefile b/lang/python/python-atomicwrites/Makefile
new file mode 100644
index 000000000..315f2c33c
--- /dev/null
+++ b/lang/python/python-atomicwrites/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-atomicwrites
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=atomicwrites
+PKG_HASH:=75a9445bac02d8d058d5e1fe689654ba5a6556a1dfd8ce6ec55a0ed79866cfa6
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-atomicwrites
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Atomic file writes
+ URL:=https://github.com/untitaker/python-atomicwrites
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-atomicwrites/description
+ Python library for atomic file writes.
+endef
+
+$(eval $(call Py3Package,python3-atomicwrites))
+$(eval $(call BuildPackage,python3-atomicwrites))
+$(eval $(call BuildPackage,python3-atomicwrites-src))