aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-17 15:33:08 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-17 15:42:53 -0700
commit92258da65afe115b20dba6e2b7896b01b59807fc (patch)
treed8dd499c3fc42d6f2eafbbe540fd409dada6c667
parent3e33919d1025e26760b200a3442b39bf1f4f0fc9 (diff)
gpsd: Fix pkgconfig file for libgps
This ensures it can be found properly by any package that uses pkgconfig to find libgps. Nothing in the tree currently does. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/gpsd/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/utils/gpsd/Makefile b/utils/gpsd/Makefile
index 721e3197b..a6756659d 100644
--- a/utils/gpsd/Makefile
+++ b/utils/gpsd/Makefile
@@ -9,19 +9,19 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gpsd
PKG_VERSION:=3.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
PKG_HASH:=27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39
-PKG_BUILD_DEPENDS:=scons/host
-
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:berlios:gps_daemon
+PKG_BUILD_DEPENDS:=scons/host
+
include $(INCLUDE_DIR)/package.mk
include ../../devel/scons/scons.mk
@@ -112,9 +112,9 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgps*.pc \
- $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgps.pc $(1)/usr/lib/pkgconfig
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libgps.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/libgps.pc
endef
define Package/gpsd/install