aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-03-08 17:18:09 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-03-09 09:23:10 +0200
commit92073b047bb862627db5b264c3ee7cc79ba49649 (patch)
tree7b83c182bec1ca97f19b7960b3211e763bd67ca8
parenta85b0b6b57a9a6a15d018ec7f475e6d561c46169 (diff)
python,python3: drop tests from all core packages
Well, this slipped by for some time. This should make the Python core packages even more lighter. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python3/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 4300eef71..25d07fbd4 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -104,6 +104,8 @@ define PyBasePackage
define PyPackage/$(1)/filespec
ifneq ($(2),)
$(subst $(space),$(newline),$(foreach lib_file,$(2),+|$(lib_file)))
+ -|/usr/lib/python$(PYTHON_VERSION)/*/test
+ -|/usr/lib/python$(PYTHON_VERSION)/*/tests
endif
endef
endef
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 1276ae546..a0711a3f6 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -98,6 +98,8 @@ define Py3BasePackage
define Py3Package/$(1)/filespec
ifneq ($(2),)
$(subst $(space),$(newline),$(foreach lib_file,$(2),+|$(lib_file)))
+ -|/usr/lib/python$(PYTHON_VERSION)/*/test
+ -|/usr/lib/python$(PYTHON_VERSION)/*/tests
endif
endef
endef