aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2021-02-25 14:46:21 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2021-03-02 10:33:19 +0100
commit9103076ec73aa1e941e1316075f8a1e8ca053bfe (patch)
treedf5ea183edb70fff47a420c777eb37ed448dd5a1
parent8be55bb93f21597d44689b558ad0dfb1c986d044 (diff)
knot-resolver: update to version 5.3.0
Changes: - remove arch limit - add libnghttpd2 dependency Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
-rw-r--r--net/knot-resolver/Makefile8
-rw-r--r--net/knot-resolver/patches/030-fix-policy-hack.patch2
2 files changed, 5 insertions, 5 deletions
diff --git a/net/knot-resolver/Makefile b/net/knot-resolver/Makefile
index 464754927..ceec3d1d0 100644
--- a/net/knot-resolver/Makefile
+++ b/net/knot-resolver/Makefile
@@ -10,12 +10,12 @@ PKG_RELRO_FULL:=0
include $(TOPDIR)/rules.mk
PKG_NAME:=knot-resolver
-PKG_VERSION:=5.2.1
+PKG_VERSION:=5.3.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-resolver
-PKG_HASH:=aa37b744c400f437acba7a54aebcbdbe722ece743d342cbc39f2dd8087f05826
+PKG_HASH:=fb6cb2c03f4fffbdd8a0098127383d03b14cf7d6abf3a0cd229fb13ff68ee33e
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
PKG_LICENSE:=GPL-3.0-later
@@ -41,10 +41,10 @@ define Package/knot-resolver
+luasec \
+luasocket \
+libstdcpp \
+ +libnghttp2 \
+lmdb \
PACKAGE_knot-resolver_dnstap:libfstrm \
- PACKAGE_knot-resolver_dnstap:libprotobuf-c \
- @(aarch64||mips64||mips64el||powerpc64||x86_64)
+ PACKAGE_knot-resolver_dnstap:libprotobuf-c
USERID:=kresd=3536:kresd=3536
endef
diff --git a/net/knot-resolver/patches/030-fix-policy-hack.patch b/net/knot-resolver/patches/030-fix-policy-hack.patch
index 6d013a6cc..a4eac6c8d 100644
--- a/net/knot-resolver/patches/030-fix-policy-hack.patch
+++ b/net/knot-resolver/patches/030-fix-policy-hack.patch
@@ -2,7 +2,7 @@ This patch fixes the problem with forwarding in knot-resolver v4.3.0.
It reintroduces a fix which enables policy related hack (knot/knot-resolver#205 (comment 94566) )
--- a/modules/policy/policy.lua
+++ b/modules/policy/policy.lua
-@@ -985,7 +985,7 @@ policy.layer = {
+@@ -982,7 +982,7 @@ policy.layer = {
if bit.band(state, bit.bor(kres.FAIL, kres.DONE)) ~= 0 then return state end
local qry = req:initial() -- same as :current() but more descriptive
return policy.evaluate(policy.rules, req, qry, state)