aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2019-01-27 11:43:42 +0200
committerGitHub <noreply@github.com>2019-01-27 11:43:42 +0200
commit8f14b6deac8684e9d987af56a48505465b9492ab (patch)
tree4c1c5b584655d10233b3b187b1bb33470af072b7
parent3609c70c07e8ba87cb196c612c4a8fc9d119adc4 (diff)
parentcb6e9c6f2134f681c0870641dfc63de0a2debd95 (diff)
Merge pull request #8010 from neheb/hdp
hdparm: Fix LDFLAGS
-rw-r--r--utils/hdparm/Makefile3
-rw-r--r--utils/hdparm/patches/010-ldflags.patch13
2 files changed, 13 insertions, 3 deletions
diff --git a/utils/hdparm/Makefile b/utils/hdparm/Makefile
index e095af4ad..78b7b9906 100644
--- a/utils/hdparm/Makefile
+++ b/utils/hdparm/Makefile
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hdparm
PKG_VERSION:=9.58
PKG_RELEASE:=1
-PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -21,8 +20,6 @@ PKG_LICENSE:=BSD-Style Open Source License
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS+=-D_GNU_SOURCE
-
define Package/hdparm
SECTION:=utils
CATEGORY:=Utilities
diff --git a/utils/hdparm/patches/010-ldflags.patch b/utils/hdparm/patches/010-ldflags.patch
new file mode 100644
index 000000000..e4778748d
--- /dev/null
+++ b/utils/hdparm/patches/010-ldflags.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,9 +13,8 @@ oldmandir = $(manprefix)/man
+ CC ?= gcc
+ STRIP ?= strip
+
+-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
++CFLAGS ?= -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
+
+-LDFLAGS = -s
+ #LDFLAGS = -s -static
+ INSTALL = install
+ INSTALL_DATA = $(INSTALL) -m 644