aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-10 16:38:05 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-10 16:38:05 -0800
commit8dda6b8f2f14c0d27df36e8f9293037e46e0a99e (patch)
tree83db2421eb89b09550c810d1632e2d887e4e4991
parent7e36a24dd3a99ba4085d2f4318bef8b8cf0bb318 (diff)
pytz: Update to 2018.7 and add host build
Django 1.11 and above needs pytz to run properly. This was causing issues with seahub, whose Makefile uses django-admin to compile locales. Also removed InstallDev. It tried to accomplish the same thing but ended up installing to the same directories anyways. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/python/pytz/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/lang/python/pytz/Makefile b/lang/python/pytz/Makefile
index fc51478f0..9cdb69ec6 100644
--- a/lang/python/pytz/Makefile
+++ b/lang/python/pytz/Makefile
@@ -8,14 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pytz
-PKG_VERSION:=2018.6
+PKG_VERSION:=2018.7
PKG_RELEASE:=1
PKG_LICENSE:=MIT
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pytz
-PKG_HASH:=642253af8eae734d1509fc6ac9c1aee5e5b69d76392660889979b9870610a46b
+PKG_HASH:=31cb35c89bd7d333cd32c5f278fca91b523b0834369e757f4c5641ea252236ca
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
@@ -37,13 +38,12 @@ define Build/Compile
$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
endef
-define Package/pytz/InstallDev
- $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
- $(CP) \
- $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
- $(1)$(PYTHON_PKG_DIR)
+define Host/Compile
+ $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
endef
+Host/Install:=
+
define Package/pytz/install
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
$(CP) \
@@ -51,4 +51,5 @@ define Package/pytz/install
$(1)$(PYTHON_PKG_DIR)
endef
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,pytz))