aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2021-02-21 08:56:45 +0100
committerGitHub <noreply@github.com>2021-02-21 08:56:45 +0100
commit8dc0d3d33a434ac31e4b231ff98c10fd00cf87fc (patch)
tree2bee928bd12483c82c890d6ee8fb643b05044ab3
parent937a733854f32ee2d05b162909363464814efba7 (diff)
parent0bc2f89ae1d77de2f5a5ebb54b8e56f6d7e22b23 (diff)
Merge pull request #13929 from ja-pa/git-lfs
git-lfs: add new package
-rw-r--r--net/git-lfs/Makefile46
-rw-r--r--net/git-lfs/test.sh3
2 files changed, 49 insertions, 0 deletions
diff --git a/net/git-lfs/Makefile b/net/git-lfs/Makefile
new file mode 100644
index 000000000..2c388bdd9
--- /dev/null
+++ b/net/git-lfs/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2020-2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=git-lfs
+PKG_VERSION:=2.13.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/git-lfs/git-lfs/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=782e6275df9ca370730945112e16a0b8c64b9819f0b61fae52ba1ebbc8dce2d5
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.md
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/git-lfs/git-lfs
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+define Package/git-lfs
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Git Large File Storage
+ URL:=https://git-lfs.github.com
+ DEPENDS:=$(GO_ARCH_DEPENDS) +git
+endef
+
+define Package/git-lfs/description
+ Git Large File Storage (LFS) replaces large files such as audio samples,
+ videos, datasets, and graphics with text pointers inside Git, while storing
+ the file contents on a remote server like GitHub.com or GitHub Enterprise.
+endef
+
+$(eval $(call GoBinPackage,git-lfs))
+$(eval $(call BuildPackage,git-lfs))
diff --git a/net/git-lfs/test.sh b/net/git-lfs/test.sh
new file mode 100644
index 000000000..c85566d88
--- /dev/null
+++ b/net/git-lfs/test.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+git-lfs --version|grep "$2"