aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2018-08-23 22:04:31 +0200
committerMichael Heimpold <mhei@heimpold.de>2018-08-23 22:13:11 +0200
commit8d2764f1938cc0be5d6bdfbf5e68d8be61b00118 (patch)
treebd03767ee33fa9d94a183cabc25287451b834fdb
parentd97e89d2568ac3f480d0510506a3d8652ea9f30d (diff)
php7: add dependency to hash for mysqlnd
The following error shows that mysqlnd depends on functions provided by hash: root@OpenWrt:/etc/php7# php-cli -m PHP Warning: PHP Startup: Unable to load dynamic library 'mysqlnd.so' (tried: /usr/lib/php/mysqlnd.so (Error relocating /usr/lib/php/mysqlnd.so: PHP_SHA256Final: symbol not found), /usr/lib/php/mysqlnd.so.so (Error loading shared library /usr/lib/php/mysqlnd.so.so: No such file or directory)) in Unknown on line 0 So let's model this dep in package metadata. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--lang/php7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 99e98b3b9..08d1da1c1 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.2.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -608,7 +608,7 @@ $(eval $(call BuildModule,json,JSON))
$(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php7-mod-ldap:libopenldap +PACKAGE_php7-mod-ldap:libsasl2))
$(eval $(call BuildModule,mbstring,MBString))
$(eval $(call BuildModule,mysqli,MySQL Improved Extension,+PACKAGE_php7-mod-mysqli:php7-mod-mysqlnd,30))
-$(eval $(call BuildModule,mysqlnd,MySQL Native Driver))
+$(eval $(call BuildModule,mysqlnd,MySQL Native Driver,+php7-mod-hash))
$(eval $(call BuildModule,opcache,OPcache,,,zend))
$(eval $(call BuildModule,openssl,OpenSSL,+PACKAGE_php7-mod-openssl:libopenssl))
$(eval $(call BuildModule,pcntl,PCNTL))