aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-08-12 21:18:33 +0200
committerSteven Barth <steven@midlink.org>2014-08-12 21:18:56 +0200
commit8c9c803128db14a2ea8c0e3da83f21957ac8f38a (patch)
tree2de2ec376c4924d575dcf447b98fae8122846293
parent887411b8c383d30221140805d20ac39e2ea4e143 (diff)
picocom: import and adopt
Signed-off-by: Steven Barth <steven@midlink.org>
-rw-r--r--utils/picocom/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/utils/picocom/Makefile b/utils/picocom/Makefile
new file mode 100644
index 000000000..b5251b412
--- /dev/null
+++ b/utils/picocom/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=picocom
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://picocom.googlecode.com/files
+PKG_MD5SUM:=8eaba1d31407e8408674d6e57af447ef
+
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_LICENSE:=GPL-2.0+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/picocom
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A minimal dumb-terminal emulation program
+ URL:=http://code.google.com/p/picocom/
+ SUBMENU:=Terminal
+endef
+
+define Package/picocom/description
+ minimal dumb-terminal emulation program
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" \
+ picocom
+endef
+
+define Package/picocom/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/picocom $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,picocom))