aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-03 14:35:39 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-03 21:37:03 -0700
commit8c23fef9dace93ef742093da8468e84057337c56 (patch)
treea611b5e43aa99d78d04fa947c5034a69d87ad37d
parent2b9f88a4bfd51bf3665c5ba4d5fa8eaafe2966a7 (diff)
zstd: update to 1.4.5
Switch to zst archives for smaller size. Removed patches in favor of a better solution for uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/zstd/Makefile12
-rw-r--r--utils/zstd/patches/010-mtime.patch23
-rw-r--r--utils/zstd/patches/020-util.patch22
3 files changed, 7 insertions, 50 deletions
diff --git a/utils/zstd/Makefile b/utils/zstd/Makefile
index f968f6b4b..2542e087c 100644
--- a/utils/zstd/Makefile
+++ b/utils/zstd/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zstd
-PKG_VERSION:=1.4.4
-PKG_RELEASE:=3
+PKG_VERSION:=1.4.5
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/facebook/zstd/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=a364f5162c7d1a455cc915e8e3cf5f4bd8b75d09bc0f53965b0c9ca1383c52c8
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
+PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
+PKG_HASH:=2c2366874bc449ff539614266d8c0d6ecdb4baf30bb65609c239ab4ed23c03c7
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later
@@ -64,6 +64,8 @@ ifeq ($(CONFIG_ZSTD_OPTIMIZE_O3),y)
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O3
endif
+TARGET_CFLAGS += $(if $(CONFIG_USE_UCLIBC),-D_BSD_SOURCE)
+
MESON_ARGS += \
-Dlegacy_level=1 \
-Ddebug_level=0 \
diff --git a/utils/zstd/patches/010-mtime.patch b/utils/zstd/patches/010-mtime.patch
deleted file mode 100644
index 10ad8612c..000000000
--- a/utils/zstd/patches/010-mtime.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From f62cf1fff5dabcfaaa8c85638723bc19842f52f4 Mon Sep 17 00:00:00 2001
-From: Sergey Dryabzhinsky <sergey.dryabzhinsky+github@gmail.com>
-Date: Tue, 19 Nov 2019 23:15:28 +0300
-Subject: [PATCH] Fix typo in util.c
-
-There must be mtim*e*
----
- programs/util.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/programs/util.c b/programs/util.c
-index 5d15450d2..d3ffc1133 100644
---- a/programs/util.c
-+++ b/programs/util.c
-@@ -73,7 +73,7 @@ int UTIL_setFileStat(const char *filename, stat_t *statbuf)
- {
- /* (atime, mtime) */
- struct timespec timebuf[2] = { {0, UTIME_NOW} };
-- timebuf[1] = statbuf->st_mtim;
-+ timebuf[1] = statbuf->st_mtime;
- res += utimensat(AT_FDCWD, filename, timebuf, 0);
- }
- #endif
diff --git a/utils/zstd/patches/020-util.patch b/utils/zstd/patches/020-util.patch
deleted file mode 100644
index 74f652e2d..000000000
--- a/utils/zstd/patches/020-util.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 612a06eb3ef7f42739ace99fbca6ad63b788d46c Mon Sep 17 00:00:00 2001
-From: Sergey Dryabzhinsky <sergey.dryabzhinsky+github@gmail.com>
-Date: Tue, 19 Nov 2019 23:24:00 +0300
-Subject: [PATCH] Update util.c
-
----
- programs/util.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/programs/util.c b/programs/util.c
-index d3ffc1133..aa75ca6d4 100644
---- a/programs/util.c
-+++ b/programs/util.c
-@@ -73,7 +73,7 @@ int UTIL_setFileStat(const char *filename, stat_t *statbuf)
- {
- /* (atime, mtime) */
- struct timespec timebuf[2] = { {0, UTIME_NOW} };
-- timebuf[1] = statbuf->st_mtime;
-+ timebuf[1].tv_sec = statbuf->st_mtime;
- res += utimensat(AT_FDCWD, filename, timebuf, 0);
- }
- #endif