aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-01 14:06:24 -0700
committerGitHub <noreply@github.com>2020-09-01 14:06:24 -0700
commit8966849a5a723169bd98519898d0132d6e7341ce (patch)
tree0e7596ebf145672bd39fd674f2ba3fc7757d6c01
parent42e447c32a156a750f36bc6a49ac70d37d02b8d8 (diff)
parentd897beee917a9de1f7494bea0898ae13094e2b1f (diff)
Merge pull request #13262 from neheb/ksm
kismet: fix compilation under uClibc-ng and GCC10
-rw-r--r--net/kismet/Makefile2
-rw-r--r--net/kismet/patches/040-uclibc.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/net/kismet/Makefile b/net/kismet/Makefile
index baacf6e46..4a0e624a7 100644
--- a/net/kismet/Makefile
+++ b/net/kismet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kismet
PKG_VERSION:=2016-07-R1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_LICENSE:=LGPLv2.1
PKG_CPE_ID:=cpe:/a:kismet:kismet
diff --git a/net/kismet/patches/040-uclibc.patch b/net/kismet/patches/040-uclibc.patch
new file mode 100644
index 000000000..f63a5da52
--- /dev/null
+++ b/net/kismet/patches/040-uclibc.patch
@@ -0,0 +1,12 @@
+--- a/ipc_remote.cc
++++ b/ipc_remote.cc
+@@ -941,8 +941,8 @@ int RootIPCRemote::OpenFDPassSock() {
+ }
+
+ typedef struct {
+- struct cmsghdr header;
+ int fd;
++ struct cmsghdr header;
+ } __attribute__((packed)) cmsg_fd;
+
+ int RootIPCRemote::SendDescriptor(int in_fd) {